Unable to io.druid.cli.Main latest SNAPSHOT distribution

Hey,

I’m on :

Linux

openjdk version “1.8.0_91”

OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14)

OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

And I’m trying to use this PR https://github.com/druid-io/druid/pull/3399 so I :

  1. cloned this branch

  2. mvn clean package

  3. which gives me druid-0.9.2-SNAPSHOT and mysql-metadata-storage-0.9.2-SNAPSHOT.tar.gz

  4. scripted it based on readme https://gist.github.com/l15k4/f2f0586d8e1e5febdfec6183da057e58

but however I set the classpath I get :

Error: Could not find or load main class io.druid.cli.Main

Everything seems to be legit :

$ jar -tf druid-services-0.9.2-SNAPSHOT.jar | grep Main
io/druid/cli/Main.class

``

Any idea what could be wrong? I tried everything I could think of. No matter how I put the classpath together, it always throws this error.

Instead of running the jar, try using distribution/target/druid-XXX-SNAPSHOT-bin.tar.gz. That has the same layout as the release tarballs and you can use them the same way you’d use a release.

I’m using the distribution, class path druid-0.9.2-SNAPSHOT/lib/* with 183 jars including druid-services-0.9.2-SNAPSHOT.jar with io.druid.cli.Main …

there is either some java version problem or I don’t know … I’m having a second round of investigations now :slight_smile:

Ok I repeated all the steps in a java:8 docker container and it worked … there is probably something wrong with my local environment…