Unable to parse '/hdp/apps/${hdp.version}/mapreduce/mapreduce.tar.gz#mr-framework

Hi Druid Gurus,

Our druid ( version 0.8.0) setup was running fine until we upgraded our Hadoop environment to version 2.6.0. When i tried to index data it fails due to error

Caused by: java.lang.IllegalArgumentException: Unable to parse ‘/hdp/apps/${hdp.version}/mapreduce/mapreduce.tar.gz#mr-framework’ as a URI, check the setting for mapreduce.application.framework.path

is this a druid error? any suggestions on how to resolve this? Please let me know

Regards

Karteek

Hi Karteek,

Is that setting from the mapred-site.xml that was copied to Druid’s configuration path?

If so, can you try replacing ${hdp.version} with what it would resolve to for your version of HDP, e.g.:

/hdp/apps/2.4.0.0-169/mapreduce/mapreduce.tar.gz#mr-framework

Thanks,
Jon

Thank You Jonathan. That worked. i had to make another copy that xml with the changes suggested and point my hadoop conf dir to that path and it worked

karteek

Alternatively, you can add -Dhdp.version= to druid.indexer.runner.javaOpts in runtime.properties for middlemanager.

Thank You Nishant. Will try and let you know about it.

karteek