Unable to resolve artifacts for io.druid.extensions:druid-examples:jar:0.8.0

Hi,

I downloaded Druid-0.8.0 from the tarball (also tried build from source) and ran an example…

[root@sandbox druid-0.8.0]# ./run_example_server.sh

This will run a stand-alone version of Druid

Please specify an example by its number.

Examples available:

1 - wikipedia/wikipedia_realtime.spec - No Description

2 - twitter/twitter_realtime.spec - No Description

[1] > 1

Running command:

  • java -Xmx512m -Duser.timezone=UTC -Dfile.encoding=UTF-8 -Ddruid.realtime.specFile=/root/Downloads/druid-0.8.0/examples/wikipedia/wikipedia_realtime.spec -classpath ‘/root/Downloads/druid-0.8.0/…/config/realtime:/root/Downloads/druid-0.8.0/examples/wikipedia:/root/Downloads/druid-0.8.0/config/_common:/root/Downloads/druid-0.8.0/config/realtime:/root/Downloads/druid-0.8.0/lib/*’ io.druid.cli.Main example realtime

2015-08-28T11:08:42,462 INFO [main] io.druid.guice.PropertiesModule - Loading properties from common.runtime.properties

2015-08-28T11:08:42,465 INFO [main] io.druid.guice.PropertiesModule - Loading properties from runtime.properties

Aug 28, 2015 11:08:42 AM org.hibernate.validator.internal.util.Version

INFO: HV000001: Hibernate Validator 5.1.3.Final

2015-08-28T11:08:43,174 INFO [main] io.druid.guice.JsonConfigurator - Loaded class[class io.druid.guice.ExtensionsConfig] from props[druid.extensions.] as [ExtensionsConfig{searchCurrentClassloader=true, coordinates=[io.druid.extensions:druid-examples, io.druid.extensions:druid-kafka-eight, io.druid.extensions:mysql-metadata-storage], defaultVersion=‘0.8.0’, localRepository=’/root/Downloads/druid-0.8.0/repo’, remoteRepositories=[https://repo1.maven.org/maven2/, https://metamx.artifactoryonline.com/metamx/pub-libs-releases-local]}]

2015-08-28T11:08:43,410 INFO [main] io.druid.initialization.Initialization - Loading extension[io.druid.extensions:druid-examples] for class[io.druid.cli.CliCommandCreator]

2015-08-28T11:08:51,928 ERROR [main] io.druid.initialization.Initialization - Unable to resolve artifacts for [io.druid.extensions:druid-examples:jar:0.8.0 (runtime) -> < [ (https://repo1.maven.org/maven2/, releases+snapshots), (https://metamx.artifactoryonline.com/metamx/pub-libs-releases-local, releases+snapshots)]].

java.lang.NullPointerException

at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:361) ~[aether-impl-0.9.0.M2.jar:?]

at io.tesla.aether.internal.DefaultTeslaAether.resolveArtifacts(DefaultTeslaAether.java:289) ~[tesla-aether-0.0.5.jar:0.0.5]

at io.druid.initialization.Initialization.getClassLoaderForCoordinates(Initialization.java:253) [druid-server-0.8.0.jar:0.8.0]

at io.druid.initialization.Initialization.getFromExtensions(Initialization.java:153) [druid-server-0.8.0.jar:0.8.0]

at io.druid.cli.Main.main(Main.java:76) [druid-services-0.8.0.jar:0.8.0]

Exception in thread “main” java.lang.NullPointerException

at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:361)

at io.tesla.aether.internal.DefaultTeslaAether.resolveArtifacts(DefaultTeslaAether.java:289)

at io.druid.initialization.Initialization.getClassLoaderForCoordinates(Initialization.java:253)

at io.druid.initialization.Initialization.getFromExtensions(Initialization.java:153)

at io.druid.cli.Main.main(Main.java:76)

I have set the necessary proxy configurations. When I go to https://metamx.artifactoryonline.com/metamx/pub-libs-releases-local, I don’t see libraries for druid 0.8, could that be the reason??

As a side question: How is panoramix? Can the UI be used in production?

Thanks.

Hi Sai,

Have you had a chance to read: http://druid.io/docs/latest/tutorials/firewall.html?

You can try that or if you try 0.8.1-RC2, it has all the dependencies you need locally bundled so you don’t need to download them.