Unable to submit batch ingestion task

I read somewhere that to get rid of the forced time chuck lock (because I am not appending) I can use forceTimeChunkLock:false but not sure where I can add it in the spec, any idea

The docs describe it as an overlord configuration parameter, take a look here: Configuration reference · Apache Druid