Unknown provider[postgresql] of Key[type=org.apache.druid.metadata.MetadataStorageProvider

Hi, I am deploying apache-druid:0.20.1 on Kube. I am getting error:

Unknown provider[postgresql] of Key[type=org.apache.druid.metadata.MetadataStorageProvider, annotation=[none]],

                          

I have postgresql-metadata-storage in extension.loadlist though. I also tried changing the order of extensions and keeping postgres before S3, but still facing the issue. Please suggest. Thanks.

Suggest checking that common.runtime.properties on all your nodes is sync’d OK, and you might also want to check that the extensions folder includes the postgresql-metadata-storage folder.

You can use the /status API to confirm loaded extensions on each service, too - they appear in the modules section.