Upgrading to 0.16 trouble

Hi,

since we are still on 0.13, I was hyper hyper to upgrade. However the first historical node is not picked up by the old coordinator. I checked, it’s in zk /druid/annoucements - but somehow my old coordinator is not understanding the node.

Any idea what to do?

Thanks!

Hagen

Hey Hagen,

I’m don’t recall the details, but you might need to go through an intermediary version first.

Or, if you were using http segment announcing, there’s a relevant note in the 0.14.0 notes; see “Segment announcing” on https://github.com/apache/incubator-druid/releases/tag/druid-0.14.0-incubating.

Gian

Thanks Gian,

I have both

druid.announcer.type=http

druid.serverview.type=http

in my config, but it’s not working. I tried

druid.announcer.type=http

druid.serverview.type=batch

but that’s not working either. The node is simply ignored by the coordinator (and the brokers).

So I guess, I have to go to batch first, then upgrade, then go to http again? Any recommendation on how do do that safely?

Or should I pick an intermediate version? If yes, which one?

Thanks!

Hagen

Since you didn’t respond, I tried 0.14.2 - this one is joining the cluster.

I am on vacation now, so I will postpone the upgrade and use 0.14.2 as an intermediate version. Hopefully, I can go to 0.16 from 0,14.2.

Cheers,

Hagen

Hi, apologies for missing the opportunity to reply.

Glad to hear that the 0.14.2 fellow joined okay, thanks for reporting back. The release notes for 0.15.0 and 0.16.0, together, should tell you if the upgrade directly 0.14.x from 0.16.0 is going to work or not. Or you could try it :slight_smile:

Hi Gian,

sorry, I was on vacation. Turns out, I had fat fingers and tried 0.13 instead of 0.14. But my colleague debugged the problem in the meantime.

Turns out, 0.13 was announcing in lower case and starting from 0.14 in upper case. Other than that, it seemed compatible.

https://github.com/liquidm/druid/commit/382e1126850906647b8ca14d5433815418206e43

https://github.com/liquidm/druid/commit/2047afb1d096ee3127af2614aa3e8032855fb06d

With these two commits we were able to make a transition version and are now on 0.14. I will upgrade to 0.16 now, let’s see how it goes.

Cheers,

Hagen