Using tranquility-core_2.11 with jdk11

I am trying to use tranquility-core to push data to druid but the thread gets parked(public native void park(boolean var1, long var2)[Unsafe]) in the scala stack-
DruidBeam.fromConfig(…)

Is the a solution wherein tranquility-core can be used with jdk11 or is there an effective workaround for the same?

I am building and running a project with maven with tranqulity-core as one of the dependencies.

<dependency>
    <groupId>io.druid</groupId>
    <artifactId>tranquility-core_2.11</artifactId>
    <version>0.8.2</version>
</dependency>

Please help.

Hi,

Tranquility is not very actively being developed now. Druid doesn’t support JDK 11 yet and I believe Tranquility doesn’t too.

Please consider using Kafka/Kinesis indexing service instead.

Jihoon