When I startup broker

unrecognized option: -server Error Could not create the java virtual Machine. Error: A fatal exception has occurred. Program will exit.

``

Hi,
Early assumptions is that the memory configurations are either incorrect or the machine doesn’t have enough resources to start the jvm.

-Robert

I am sure the memory resources of the machine are sufficient, and the remaining 483g Leisure. I adjusted the configuration file many times.

The memory state of my server:
[root@XM-20 druid-0.13.0]# free -m

total used free shared buffers cached

Mem: 516572 238582 277990 0 1598 216448

-/+ buffers/cache: 20535 496036

``

broker jvm.config:
-server

-Xms5g

-Xmx10g

-XX:NewSize=2g

-XX:MaxNewSize=2g

-XX:MaxDirectMemorySize=24g

-Duser.timezone=UTC+0800

-Dfile.encoding=UTF-8

-Djava.io.tmpdir=/data/druid/javaiotmp

-Djava.util.logging.manager=org.apache.logging.log4j.jul.LogManager

``

broker runtime.properties:

druid.service=druid/broker

druid.host=10.130.190.20

druid.plaintextPort=8082

HTTP server threads

druid.broker.http.numConnections=20

druid.server.http.numThreads=20

Processing threads and buffers

druid.processing.buffer.sizeBytes=2147483647

druid.processing.numMergeBuffers=2

druid.processing.numThreads=7

druid.processing.tmpDir=/data/druid/brokerprocesstmp

Query cache

druid.broker.cache.useCache=true

druid.broker.cache.populateCache=true

druid.cache.type=local

druid.cache.sizeInBytes=60000000

SQL

druid.sql.enable=true

``

when I run:
[root@XM-20 druid-0.13.0]# java cat conf/druid/broker/jvm.config | xargs -cp conf/druid/_common:conf/druid/broker:lib/* org.apache.druid.cli.Main server broker

Unrecognized option: -server

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

``

Thank you for your help!

Can you provide me with a configuration reference?

Hi, I am by no means an expert here but would like to ask have you tried to rerun your command in double quotes? “conf/druid/_common:conf/druid/broker:lib/*”

From the description it seems like an environment issue, probably you are using an older version of JDK which does not support “-server” option.
I would suggest to check and verify your JDK installation. Druid 0.13 will need java8.